Announcement

Collapse
No announcement yet.

Help with a patch...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with a patch...

    I cannot get the patch for SNES FFIII, "Final fantasy VI: The Eternal Crystals" to work on ZSNES nor SNES9X. I have tried eveything I know...Re-naming the files within the rom & the patch to the same name, using SNES Tool to remove the rom header. These methods work on other patches for FFIII & other SNES rpm patches, but not for this'n. I know the rom is a good USA rom, and I downloaded the patch from Zophar's Domain, so I don't think I have a buggy product.

    I am using mostly ZSNES, V. 1.51. , but if necessary I can use an older version, or SNES9X. Any suggestions, anyone?
    I come from a smart family...In the Civil War, my great-grandpa fought for the WEST.

  • #2
    Have You tried just using a clean rom with the ips patch renamed so it has the almost the same file name as the rom(with .ips at the end of it)? like for example FF6.smc FF6.ips...the new versions of snes9x and zsnes have a autoips patching support if the rom name is the same as the ips name(in the same directory)...

    Comment


    • #3
      One thing that comes to mind here, is the patch may be for something other than the US version.

      Comment


      • #4
        Here's what i've done so far...

        ...Downloaded USA roms for both version 1.0 & V1.1.(The patch sez it's for USA roms.)
        ...renamed all files within both the rom & patch folders to the exact same name, except for the type of file, of course.
        ...Removed the rom header with SNES Tool.
        ...Placed the renamed patch file within the folder containing the rom, & removed the SNES Tool files from that folder.

        ...I change the folder's name so I won't confuse it with an unpatched copy of FF3.

        When I use the folder with the renamed .smc and .ips files, but without removing the header, it boots up the title screen for the patch, but there's no sound & the game doesn't run. When I remove the header from the rom, I get only a black screen.

        The patch sez it's for a USA rom, LMZ, but you know a lot more than I do about these things, so I'll try a Euroversion.

        Thanx for the suggestions so far! I'll keep experimenting & letcha know what happens, but I'm still open to any suggestions you may have. (I AM A *NOOB* TO ROM PATCHING!)
        I come from a smart family...In the Civil War, my great-grandpa fought for the WEST.

        Comment


        • #5
          Great news!

          Hey, I got the patched rom to work on ZSNES V1.42! I'll letcha know if I have any more probs, & I'll code it out for PAR codes, posting them in the appropriate forum/thread.

          Again, THANX for the advice! It'll be a big help for me in patching other SNES codes.
          I come from a smart family...In the Civil War, my great-grandpa fought for the WEST.

          Comment

          Working...
          X